CVSS 3.1 LOW

CKEditor: Cross-site scripting (XSS) in the engine package

Mã khác
GHSA-v6mg-96c6-gmpq
Công bố
Cập nhật
Lần đầu thấy
Nguồn
GitHub Advisory, NVD, CVE.org, OSV.dev

Mô tả

Impact

A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability could be triggered by inserting specially crafted markup under a specific General HTML Support configuration that allows inserting objects, leading to unauthorized JavaScript code execution in a browser context isolated from the origin of the application embedding the editor.

This vulnerability affects only installations where General HTML Support is enabled and configured to allow the affected HTML content.

Patches

The problem has been recognized and patched. The fix will be available in version 48.5.1 (and above) and 47.7.4 (LTS).

For more information

Email us at security@cksource.com if you have any questions or comments about this advisory.

Điểm và phân loại

CVSS
3.1 LOW v3.1
Nguồn điểm
NVD
Mức độ (theo nguồn)
LOW
EPSS
0.25%
CWE
CWE-79

Vector CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N

Ảnh hưởng

Package Bản bị ảnh hưởng Bản đã sửa
npm ckeditor5 >= 29.0.0, < 47.7.4 47.7.4
npm @ckeditor/ckeditor5-engine >= 29.0.0, < 47.7.4 47.7.4
npm ckeditor5 >= 48.0.0, < 48.5.1 48.5.1
npm @ckeditor/ckeditor5-engine >= 48.0.0, < 48.5.1 48.5.1

Sản phẩm

  • ckeditor ckeditor5

Vì sao bị lọc

  • CVSS 3.1 < 8.0 và không thuộc CISA KEV

Loại tác động

Không nhận ra loại tác động nào từ CWE, vector hay mô tả.

Dữ liệu riêng của nguồn

CVE.org · Đơn vị cấp mã
GitHub_M
OSV.dev · ID
GHSA-v6mg-96c6-gmpq

Tham khảo