CVSS 8.1 HIGH

CKEditor: Cross-site scripting (XSS) in the engine package

Mã khác
GHSA-rh54-vffm-5fvp
Công bố
Cập nhật
Lần đầu thấy
Nguồn
GitHub Advisory, NVD, CVE.org, OSV.dev

Mô tả

Impact

A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability is caused by a prototype pollution issue in the es-toolkit library used in the CKEditor 5 codebase. This vulnerability could lead to unauthorized JavaScript code execution when the editor processes incoming style attribute values.

The underlying issue has been patched by the library maintainers, and the fix has been incorporated into CKEditor 5.

Patches

The problem has been recognized and patched. The fix will be available in version 48.5.1 (and above) and 47.7.4 (LTS).

For more information

Email us at security@cksource.com if you have any questions or comments about this advisory.

Điểm và phân loại

CVSS
8.1 HIGH v3.1
Nguồn điểm
NVD
Mức độ (theo nguồn)
HIGH
EPSS
0.5%
CWE
CWE-79

Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Ảnh hưởng

Package Bản bị ảnh hưởng Bản đã sửa
npm ckeditor5 >= 45.0.0, < 47.7.4 47.7.4
npm @ckeditor/ckeditor5-engine >= 45.0.0, < 47.7.4 47.7.4
npm ckeditor5 >= 48.0.0, < 48.5.1 48.5.1
npm @ckeditor/ckeditor5-engine >= 48.0.0, < 48.5.1 48.5.1

Sản phẩm

  • ckeditor ckeditor5

Vì sao được giữ

  • CVSS 8.1 >= 8.0

Loại tác động

Không nhận ra loại tác động nào từ CWE, vector hay mô tả.

Dữ liệu riêng của nguồn

CVE.org · Đơn vị cấp mã
GitHub_M
OSV.dev · ID
GHSA-rh54-vffm-5fvp

Tham khảo