CVSS 5.3 MEDIUM Truy cập trái phép

Advanced Custom Fields: Extended <= 0.9.2.7 - Missing Authorization to Unauthenticated Data Exposure via Multiple AJAX Endpoints

Công bố
Cập nhật
Lần đầu thấy
Nguồn
NVD, CVE.org

Mô tả

The Advanced Custom Fields: Extended plugin for WordPress is vulnerable to unauthorized access of data and triggering of server-side actions in all versions up to, and including, 0.9.2.7. This is due to multiple AJAX handlers registered for unauthenticated users (wp_ajax_nopriv_*) that fail to implement proper current_user_can() authorization checks. While these handlers use ACF's acf_verify_ajax() function to validate cryptographic nonces, the acf_nonce values are generated for guest users and publicly exposed in the page source of any frontend page utilizing an ACF form. This makes it possible for unauthenticated attackers to extract the guest nonce and bypass WordPress visibility permissions, leading to the unauthorized disclosure of post titles and internal Flexible Content layout structures. The vulnerability was partially patched in version 0.9.2.4.

Điểm và phân loại

CVSS
5.3 MEDIUM v3.1
Nguồn điểm
NVD
Mức độ (theo nguồn)
MEDIUM
EPSS
—
CWE
CWE-862

Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Ảnh hưởng

Sản phẩm

  • hwk-fr Advanced Custom Fields: Extended

Vì sao bị lọc

  • CVSS 5.3 < 8.0 và không thuộc CISA KEV

Loại tác động

Truy cập trái phép
CWE-862; từ khoá "missing authorization"

Dữ liệu riêng của nguồn

CVE.org · Đơn vị cấp mã
Wordfence
CVE.org · SSVC
Tự động hoá được: yes · Khai thác: none · Tác động kỹ thuật: partial

Tham khảo